»

Hampeh lagi!


I was thinking to change my line from Digi to Celcom. I am sick of my streamyx connection, its on and off services. I should have known that Celcom, being another subsidiary company under TM, just like streamyx their service will more or less sucks as well.

But anyway last Thursday I was at this shopping mall and I saw Celcom’s booth so I stopped by and checked out their rates, services offered. Yes, no doubt their rates is the cheapest in town and I was tempted, so I registered. The dealer said Celcom will call me personally in 2 working days to confirm my number. Yea, right, I waited for the whole week no single call from them.

And only when I went back to the booth on Wednesday (because I planned to get a 3G sim card as well if Celcom havent activate my number) I knew that Celcom already activated my number. So, ok. This morning I put in my new sim card, then tried to surf some sites using the gprs. Hmm everything was good until I tried to login at one site. After keyed in my username and password and clicked enter, I was bounced back to the login page.

Ah,mayb this site got problem, I thought. So I went a forum and try to login, same thing happened. After trying few sites that reguire me to login, messenger, email, friendster, the same problem occured. Before this I was using Digi gprs to surf these same sites on the same phone and I never face this problem so I suspected that my existing Celcom gprs setting was not done properly. (but still can surf? weird) So the whole day was spent talking to the customer service people at Celcom.

Few things that made me feel regretted to switch to Celcom after today’s experience with them. Such as, it took them damn too long to attend to my call, for them to send an automatic gprs setting to my phone, I will be charged 0.40sen (not to say I’m that kedekut cheapskate person but this kind of things should be free. Digi give it for free, Maxis as well.

Being biggest telco provider why Celcom cannot do that ?), then when I said my phone model is nokia 6680, they told me that they dont have automatic setting for the model and ask me to call back using another phone and manually do the setting. WTF? This is so not good to hear. It’s not like my phone model is the latest in town, they should have the auto setting for now. (yes digi and maxis got it).

 So I called again using other phone and they passed me to the technical dept. When I told them that my login problem and how I can still surf using gprs, thex confirmed that nothing wrong with my setting since I can surf. I was told that some sites will not allow me to login because my using gprs is unsecure connection. Bullshit, I log in everyday using Digi gprs no problem at all. Cut the story short end of the day my problem still not solved.

So I switched back to Digi, login here and post this. (yeah I tried unsuccessfully login here using Celcom gprs)

Celcom memang hampeh!

You probably want to check out these posts as well:

Drop a comment :)

Page 1 of 11